Lab 5 Band Ratios and Principal Components
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 3 data.

The objective of this lab is to use Information Extraction tools (see Chapter 9 Digital
Image Processing for discussion) to process multispectral Landsat data in Reflectance.
The tasks we will complete with this lab are done with tools in the ENVI Toolbox.

Three digital files are to be uploaded to the instructor and eight questions are to be
answered on the last pages of this handout.

IMPORTANT NOTE: ENVI does not retain display enhancements for images when you
use Save As. These include rotating, zooming, contrast, brightness, sharpening,
stretching, Portals, or viewing multiple layers. Use the Export View To > Image File to
retain display enhancements and original scale (choose Zoom Factor 1.0000).

We will use Landsat 8 bands of Thermopolis that have been converted from radiance to
reflectance to ensure our band ratios are accurate. Reflectance data are also required
for spectral libraries that we will work with in a later lab. The data set is located in the
“Remote Sensing Digital Database \ Ch_3_Landsat” folder.

1) Start up ENVI

Open the subfolder “Plates_7and27_Thermopolis”. Open the subfolder
“Landsat8 Reflectance _6bnds_VNIR-SWIR”.

Select “OLI_Thermopolis_Sep2015_reflectance_bnds2-7_ENVI” > Open
> Zoom to Extents

If you have your ENVI Display preferences set at “No Stretch”, the 12-bit bands
will appear white with some of the Wind River in yellow and green?!

Click-on the Histogram Stretch tool

With “No Stretch”, the histogram low and high vertical DN bars are set to “0”
and “255” (8-bit) while the data are 12-bit.
Click-on the contrast stretch drop-down menu and select “Linear 1%”
Analyze the stretched histograms in the Histogram Stretch tool.

Open the Data Manager. Move the slider all the way to the right so you can see the
wavelengths of the six Landsat 8 bands. The USGS attaches the center wavelength of
each band to the file name (excellent!) when they convert Landsat from radiance to
reflectance. The USGS also ensures the bands are correctly labelled: OLI 2 — 7.

2) Band Ratios: Band ratios (or ratio images) are prepared by (digitally) dividing the DN

1 Introduction to Remote Sensing Principles, Interpretation, and Applications
F. F. Sabins and J.M. Ellis, 2020, Waveland Press. Contact: jellis@ellis-geospatial.com



in one band by the corresponding DN in another band for each pixel in an image. Ina
ratio image, the darkest pixels represent the smallest ratio values and the lightest pixels
represent the largest ratio values. The darkest signatures are areas where the band in
the denominator (7 in the 5/7 ratio image) has a greater reflectivity (higher DN value)
than the band in the numerator. The brightest signatures show pixels where the
numerator is larger than the denominator. Bands should be corrected to reflectance
prior to band ratioing.

Look at Figures 9-25 A and C along with textbook discussion in Chapter 9.
OLI Band Ratio 4/2 (red/blue):
Spectra of weathered iron-bearing (ferrous) minerals have strong reflectance in
the visible red region of the electromagnetic spectrum (TM band 3 or OLI band 4)
wavelengths at ~0.63 to 0.69 um). Because red-colored material, or Iron-bearing
minerals, have a weak reflectance in the visible blue portion of the spectrum (TM
band 1 or OLI band 2) at ~0.45 to 0.52 um) a ratio image of TM bands 3/1 or OLI
bands 4/2 could indicate iron- stained areas. Areas with iron-staining will be
bright.

OLI Band Ratio 6/7 (SWIR1/SWIR?2)

Landsat TM band 7 (OLI band 7) is preferentially absorbed by the hydroxyl-
bearing clay minerals as compared with TM band 5 (OLI band 6); therefore, a
ratio image of TM bands 5/7 (OLI bands 6/7) could show anomalously high
concentrations of these clay minerals as bright areas.

ENVI Toolbox > Band Algebra > Band Ratios

Select Band 4 first. ENVI automatically places Band 4 in the Numerator.

Select Band 2 next. ENVI places Band 2 in the Denominator.

Click “Enter Pair” > OK

The “Band Ratios Parameters” window pops up.
Enter an Output Filename: “Landsat iron ratio_ENVI”
Accept “Floating Point” as the output data type (each pixel DN will
have a decimal place).

The iron ratio grayscale image needs to stretched.

ENVI Toolbox > Band Algebra > Band Ratios

Select Band 6 first. ENVI automatically places Band 6 in the Numerator.

Select Band 7 next. ENVI places Band 7 in the Denominator.

Click “Enter Pair” > OK

The “Band Ratios Parameters” window pops up.
Enter an Output Filename: “Landsat clay ratio ENVI”
Accept “Floating Point” as the output data type (each pixel DN will
have a decimal place).

The clay ratio grayscale image needs to stretched.
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3) Let’s open up four Views. Views > 2 X 2 Views
Slide the iron ratio image into View 2.
Slide the clay ratio image into View 3.
Turn off the iron and clay ratio images in View 1.

Zoom to Extent and Optimized Linear stretch for the View 1 (natural color), View
2 and View 3.

Views > Link Views > GeolLink active > Link All > OK
Pan around Zoom in & out
In the Cursor Value window,
select “Link Views” and “Display Information for All Views”

Question 1: Activate View 2 with the iron ratio image. Put your cursor on the brightest

pixel you see in the Chainman Shale (Red Rose Anticline (see textbook Figure 3-11H if

you don’'t remember where that is). (Show only two decimal places for the DN below).
A. What is the Data value (DN) for the bright pixel on the iron ratio image:

B. What is the Data value (DN) for the same pixel on the clay ratio image:

Question 2: Put your cursor on the brightest pixel you see in the clay ratio image in a
Wind River agricultural field (see textbook Figure 3-11H if you don’t remember where
the river is). (Show only two decimal places for the DN below).

A. What is the Data value (DN) for the bright pixel on the clay ratio image:

B. What is the Data value (DN) for the same pixel on the iron ratio image:

4) You are planning field work and only want to visit sites in the field with the highest
potential iron content and potential clay content. To make a useful map we can
interactively determine which pixels we want to be pure white and which we want to be
pure black. The pure white pixels have the highest potential iron and clay content in the
Thermopolis field area. In the Layer Manager, highlight View 2 with the iron ratio
image.

ENVI Toolbox > Classification > Raster Color Slices
The “Data Selection” window pops-up
Select your “Landsat_iron_ratio_ENVI” image first > OK

The “Edit Raster Color Slices: Raster Color Slice” window pops-up
(The default density slice has 16 levels and a rainbow color scheme)

Change the color scheme and the number of slices.
In the upper left corner of the window is the

“Change Color Table...” icon and next to it the
“New Default Color Slices...” icon.
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In the Change Color Table window Select “B-W Linear”
In the “New Default Color Slices” window Change 16 to 2
4 Edit Raster Color Slices: Raster Colar Slice
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In the “Edit Raster Color Slices: Raster Color Slice” window, move the vertical line
separating the black and white patterns on the histogram while looking at the grayscale
ratio image. Choose a black-white dividing DN that shows only the most promising
sites on the band ratio image for you to find iron-stained rocks at the surface — that may
indicate hydrothermal alteration and mineralization! To reduce your field area (saving
time and money), density-slice your iratio image so only a few areas have white pixels.

You can also change the “Slice Min” value in the table to the left of the histogram to
move the black/white line left and right.
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Let’s save your Black-White prospecting image for your GIS.

Ensure that the “Raster Color Slice” is checked and highlighted in your Layer
Manager (the black and white slices for the iron ratio image are in a subfolder)
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File > Export Selected File to TIFF > name the image

“Your Name_lIron_Sites_GIS”
Check the “Display result” so you can see if the output identical to your black-
white iron image in View 2.  Upload to the instructor.

5) You are now an agricultural soil scientist and want to find sites in the Thermopolis
area that have the highest potential for clay to support your proposed grape vineyard.
In the Layer Manager, highlight View 3 with the clay ratio image. Repeat the process
you did for the black-white iron image under Step 3).

Name your GIS output image “YourName_Clay_Sites_GIS”. Upload to the instructor.

6) Normalized Difference Vegetation Index (NDVI)
(see textbook Figures 9-27, 9-37)

The difference in reflectance values between NIR and red wavelengths is used to
map vegetation greenness (also termed vigor and stress). Healthy plants reflect
NIR light but absorb red light (cholorphyll). Scientists like to have a number
describe a situation — an “index”.

NDVI is an index that is normalized so the value varies between -1 and +1>
NDVI = (NIR —red) / (NIR + red)
NDVI = (OLI5—-0OLI4)/(OLI5 + OLI 4)

=(145-35) /(145 + 35) = 110/ 180 = +0.61 (healthy vegetation!)
Highlight View 4 (so the NDVI image is displayed in this empty view)

6a) ENVI Toolbox > Spectral > Vegetation > NDVI
Select the six-band Landsat dataset as the Input File

The “NDVI Calculation Parameters” window pops-up.

@ MDWT Calculation Parameters | = __|

NDVI Bands: Red 2 Near IR 4

Output Resultto @ File ) Memory

Erter Output Filename | Choose | [ Compress

L:\Textbook \R5DD_Labs'\Lab_5_Ratios and PCs'

Qutput Data Type | Floating Point

QK Cancel
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The selection of NDVI Bands is correct — the 3™ band in the dataset is red
and the 4™ band is Near IR.
Name “Landsat_NDVI_ENVI”
Leave as “Floating Point” so range of DNs in the NDVI pixels
should range between -1.0 and 1.0 (pixels with noise or error could
be outside this range) > OK

6b) Zoom to Extents > Contrast stretch with “Linear 1%”

Link View 4 with the NDVI image to the other 3 Views
Views > Link Views click-on New Link or Link All

Turn off the density slices in Views 2 and 3. Enhance all the grayscale ratio
images with “Linear 1%” Pan around and zoom in & out of the linked Views

Question 3:

A. Why do you think the clay ratio image in View 3 is so similar to the
NDVI image (vegetation greenness or vigor) image in View 47?

B. Roam around the linked Views. What type of feature has pixels on the
clay ratio image that are bright but dark on the NDVI image?
(hint: look also at the color image in view 1 — change the bands to
OLI 7-5-2 as R-G-B. Look at the iron band ratio image also).

6c) Use the Cursor Value tool and click around the NDVI grayscale image.

Question 4: A. What range of NDVI values do you find on your NDVI image?

B. Did you find any negative values?

6d) Right-click on the NDVI image in the Layer Manager > Quick Stats

Question 5:

Select Plot drop-down menu > “Histogram Band 1”

A. What range of DN values (Min and Max) do you find in the metadata for
the NDVI image?

B. Is the range of DNs in the image’s metadata different than what you
found clicking around the image with the Cursor Value tool? YES NO

C. Approximately how many pixels have values greater than +1.0?

D. Approximately how many pixels have values less than -1.07?

E. How many pixels are in this image? (Remember Metadata?)

F. What is your opinion about those pixels in the metadata with DNs
outside of the NDVI -1 to 1 range?
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It is very important to use your brain and eyes - look at the image, metadata, and
statistics - to help you understand the quality and technical issues with your imagery to
ensure that what you are doing makes sense — and that the maps you generate are
useful. We’'ll see the impact of blindly using all the DNs that are in the NDVI image in
the final NDVI exercise below.

6e) Let’s color-code the NDVI to highlight those pixels with vigorous vegetation
ENVI Tool Box > Classification > Raster Color Slices
Select the grayscale NDVIimage > OK

The ENVI density slice program uses the DN range documented in the metadata.
The “Edit Raster Color Slices: Raster Color Slice” tool pops-up. Evaluate it!
Question 6: A. What density slice colors appear on your NDVI image in View 47?
B. Is this NDVI image what you want for a final, color-coded product?

We must modify the min and max DN values that we allow to be used by the density
slice tool to reflect what we visually see in the image. The remote sensing analyst has
to make a decision about what is most valid and what is noise and needs to be ignored.
This decision should be documented in your color-coded NDVI GIS image’s metadata.

Along the top right portion of the “Edit Raster Color Slices...” window are DN
values for “Histogram Min” and “Max” automatically placed by ENVI based on the
unedited NDVI input image.

Change the Min to -1.0 and the Max to 1.0

Click-on the “New Default Color Slices...” icon in the upper left.
Change “Num Slices” from 16 to 5.
Note “Data Min” is -1.0 and “Data Max” is 1.0 in the lower left. > OK > OK

How many colors do you see on your NDVI image in View 4?

There is much research documentation that in terrain such as Thermopolis (semi arid)
we have a low probability of finding pixels with NDVI values below -0.2. GIS Resources
indicates the following NDVI values can be expected:

1. Barren rocks, sand, or snow show very low NDVI values (-0.1 to 0.1)

2. Shurbs and grasslands or senescing crops (- 0.2 to 0.5)

3. Dense vegetation or tropical rainforest (—0.6 to 0.9)

4. Deep water (-1)

ENVI’s Help indicates vegetation typically ranges between NDV1 values of 0.2 and 0.8.
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Given the above, let’s change our density slice min value to -0.1 since most of us didn’t
find any DNs more negative than -0.1 while analyzing our NDVI image with the Cursor
Value tool earlier.

6f) In the Layer Manager, Right-click on the “Slices” folder that contains the 5
colors and their ranges under the “Raster Color Slice” file > Edit Color Slices...

The same menu pops up that we saw in Exercise (6e) above. Update the Min
value to -0.1 and the Max value to 1.0. We have to reset the number of slices
also.

Click-on the “New Default Color Slices...” icon in the upper left.
Change “Num Slices” from 16 to 5.

Your color-coded histogram should look like what is shown below:
Histogram (NDVI (OLI_Thermopolis_Sep2015 reflectance bnds2-7 ENVI): b
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Histogram Count
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Data:-0.031866 Data Values > OK

Your 5-level density slice of the NDVI image should look like this. Agricultural
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fields that are heavily irrigated are displayed in red. Less vigorous (or more
open) fields are displayed in yellow and green. A very useful and new product!

File > Chip View To... > Image > Select “JPEG” in the dropdown window.
Name the color-coded NDVI image “YourName_color-coded_NDVI_jpg”
Upload to the instructor.

7) Principal Components

Highlight Views 2, 3, 4 and for each view File > Close All Files
In View 1 > Change RGB Bands to OLI 5-3-2 (NIR-Red-Green) as R-G-B
Leave 4 Views — only View 1 has an image.

Principal Components (PCs) are covered in the textbook Chapter 9,

See Figures 9-22, 9-23 A-F, 9-24 and Plate 27. The reflectance image used in this
exercise does not cover the exact same area as the textbook Landsat example which is
also in radiance. So the PCs developed in this exercise will not look exactly like the
ones in the textbook. PCs are specific to the dataset being processed.

Why PCs? When you compare the individual multispectral bands in a dataset there is
strong visual similarity. Think back to Lab 3 and the correlation matrix for the
Thermopolis Landsat bands. The high correlation means there is much redundancy of
information in the multispectral data set. PCs reduce this redundancy by compressing
all of the information contained in the original grayscale bands set into a new set of
grayscale images named PC1, PC2, PC3, etc. Each successive PC image accounts
for a progressively smaller proportion of the variation in the original data set.

Highlight View 2 (this will put the PCs into this empty View)
ENVI Toolbox > Transform > PCA Rotation > Forward PCA Rotation New Statistics
and Rotate
(PCA) means principal component analysis
Use ENVI Help to learn more about this analysis and step-by-step details
Select the 6-band Landsat data set > OK Accept Defaults for subsets & Mask > OK
The “Forward PC Parameters” window pops-up.
Name the output Stats file “Landsat_6PC_stats”
Name the output file “Landsat 6PC”
Accept defaults EXCEPT change “floating point” to “byte” > OK

The “PC Eigenvalues” window pops-up (see below) and the 6 PCs load into
View 2.
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To see the Eigenvalue values (shown on the right above), you choose Export > ASCII

in the PC Eigenvalues menu. The ASCII file is a simple .txt file that lists the PC
Eigenvalues.

NOTE: PC Eigenvalues indicate the proportion of original information (total variance) in
the multispectral dataset (all the bands) that each PC contains. To determine the
percentage of the total variance within each PC, you sum the Eigenvalues and divide
each PC Eigenvalue by the summed total.

Views > Link Views View 1 has 6 Landsat bands, View 2 has 6 PC images.
Look at the Data Manager list of bands and PCs

7a) Next we will examine the grayscale bands and PCs with “Band Animation”
Highlight View 1 > Right-click file in Layer Manager > Band Animation
Slow the flicker rate to 1 or 2 seconds
Note the high visual correlation between bands
You may have to use “Linear 1%” stretch on the bands

Highlight View 2 > Right-click file in Layer Manager > Band Animation
Note the low visual correlation between PC images
You may have to use “Linear 1%” stretch on the bands

Both Views should be in Band Animation mode, Zoom in to the Red Rose
Anticline — band animation should still be working in both Views.

7b) Let’s load a grayscale band into View 3 and a grayscale PC into View 4
Highlight View 3 > “Data Manager” > Select OLI Band 1 > Load Grayscale
OLI Band 1 will display in View 3

Highlight View 4 > “Data Manager” > Select PC Band 1 > Load Grayscale
PC Band 1 will display in View 4

Views > Link Views > Link All > OK

Zoom in to the Red Rose Anticline. In View 3 use the Data Manager to
load another OLI band. Compare a few OLI bands to PC 1.
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Question 7: A. Does the PC 1 image look very similar to the OLI bands, especially in
areas with topographic relief (ridges, cliffs, valleys, etc.)? YES NO

B. What percentage of the variance in the 6-band Landsat data set is in
PC1? (Hint: Use the values in the PC Eigenvalues table above)

C. What percentage of the variance in the 6-band Landsat data set is in
PC5? (Hint: Use the values in the PC Eigenvalues table above)

7c¢) Zoom out so both the Red Rose Anticline and the Wind River agricultural
fields are visible in the 4 views.
Highlight View 2 > Use the Data Manager > Select PC2 — PC3 - PC4 as
R-G-B > Load Data > Try different stretches > last stretch “Linear 1%”

Highlight View 3 > Use the Data Manager > Select PC4 — PC5 — PC6 as
R-G-B > Load Data > Try different stretches > last stretch “Linear 1%”

Highlight View 4 > Use the Data Manager > Select PC3 — PC4 — PC5 as
R-G-B > Load Data > Try different stretches > last stretch “Linear 1%”

Pan over the Wind River agricultural fields and note the increased level of
information available with PC color images compared with the traditional
color IR image in View 1

Question 8: A. Which PC color image in Views 2, 3, and 4 provides the most
information for you about the agricultural fields?

B. The PC color image generated from PC4-PC5-PC6 as R-G-B has what
percentage of the total variance in the 6-band Landsat dataset?
(Hint: refer to Eigenvalue table above and use your calculator)

NOTE: If we converted our NDVI grayscale image to a Mask, we could mask out the
non-vegetated terrain in the Thermopolis scene and generate more detailed and
informative PCs over the agricultural and natural vegetated areas. The Mask could be
inverted and vegetation eliminated from the PC analysis to extract more unique
patterns on the PC images over terrain with geologic outcrops.

Principal Components provide unique and often very subtle but important information
about features of interest. PCs should be applied to any multispectral data set to see
what spectral patterns may be hidden in the original bands.

The Landsat 8 OLI sensor (VNIR-SWIR) is so noise-free that the PC 5 image is almost
noise-free and even the PC 6 image displays unique spectral information. Awesome
remote sensing technology!

11 Introduction to Remote Sensing Principles, Interpretation, and Applications
F. F. Sabins and J.M. Ellis, 2020, Waveland Press. Contact: jellis@ellis-geospatial.com



12

Lab 5 Band Ratios and Principal Component Name:
Upload the following files to the instructor:
(4) “Your Name_lIron_Sites” geotiff
(5) “Your Name_Clay_Sites” geotiff

(6) “YourName_color-coded_NDVI_jpg” jpg

Question 1: Put your cursor on the brightest pixel in the Chainman Shale (Red Rose
Anticline (see textbook Figure 3-11H if you don’t remember where that is).
A. What is the Data value (DN) for the bright pixel on the iron ratio image:

B. What is the Data value (DN) for the same pixel on the clay ratio image:
Question 2: Put your cursor on the brightest pixel in a Wind River agricultural field (see
textbook Figure 3-11H if you don’t remember where the river is).

A. What is the Data value (DN) for the bright pixel on the clay ratio image:

B. What is the Data value (DN) for the same pixel on the iron ratio image:

Question 3:  A. Why do you think the clay ratio image in View 3 is so similar to the
NDVI image (vegetation greenness or vigor) image in View 47?

B. Roam around the linked What type of feature has pixels on the clay
ratio image that are bright but dark on the NDVI image?

(hint: look also at the color image in view 1 — change the bands to
OLI 7-5-2 as R-G-B. Look at the iron band ratio image also).

Question 4: A. What range of NDVI values do you find on your NDVI image?

B. Did you find any negative values?

Question 5:  A. What range of DN values (Min and Max) do you find in the metadata for
the NDVI image?

B. Is the range of DNs in the image’s metadata different than what you
found clicking around the image with the Cursor Value tool? YES NO

C. What is your opinion about those pixels in the metadata with DNs
outside of the NDVI -1 to 1 range?

12 Introduction to Remote Sensing Principles, Interpretation, and Applications
F. F. Sabins and J.M. Ellis, 2020, Waveland Press. Contact: jellis@ellis-geospatial.com



13

Question 6: A. What density slice colors appear on your NDVI image in View 4?
B. Is this NDVI image what you want for a final, color-coded product?

Question 7: A. Does the PC 1 image look very similar to the OLI bands, especially in
areas with topographic relief (ridges, cliffs, valleys, etc.)? YES NO

B. What percentage of the variance in the 6-band Landsat data set is in
PC1?

C. What percentage of the variance in the 6-band Landsat data set is in
PC5?
(Hint: Use the values in the PC Eigenvalues table above)

Question 8: A. Which PC color image provides the most information for you about the
agricultural fields?

B. The PC color image generated from PC4-PC5-PC6 as R-G-B has what
percentage of the total variance in the 6-band Landsat dataset?
(Hint: refer to Eigenvalue table above and use your calculator)
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