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Lab 2  Landsat Multispectral Processing 
Utilizes Textbook’s Remote Sensing Digital Database: Chapter 3 data. 

The objectives of this lab are to learn the processing tools on ENVI’s main display 
window that are used to interrogate, display, and display multispectral data.   

 Evaluate individual bands 
 Quick stats (overview of dataset statistics) 
 Compare an enhanced image with original USGS data 
 Spectral profile 
 Evaluate different color composites in four display Views 
 Regions of Interest (ROIs)  
 Scatter plots (feature space) 

Eight questions are asked during this lab – you are to write your answer on the sheet 
that is at the end of this handout.  Two files are to be uploaded to the instructor. 

1) Open the Remote Sensing Digital Database chapter 3 folder named “Plates_7 and 
27_Thermopolis”.  You can see that all the Landsat 8 bands and derived images that 
are explained in the textbook are contained within this folder.  Also there is a folder 
named Lab_2_Data that has other data used in this lab. 

 Open ENVI (the GIS-look option) and load the 9-band Landsat data in ENVI 
 format named:  “Thermopolis_Landsat8_bnds1-7_10-11_30m_ENVI_”.  

NOTE:  The ENVI file has more information compared with the GeoTIFF because the 
wavelength (blue, NIR, Thermal IR, etc.) can added to the band number and displayed 
in the Layer Manager and Data Manager. 

 Zoom to full extent.  Note that the first 3 bands are automatically displayed by the 
 ENVI software based on the default Preferences.  To see what bands are 
 displayed you have to click on the “+” sign to the left of the file name (see below). 
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  File > Data Manager     Lists all 9 bands in this Landsat dataset 

 Look at Figure 3-11 A-G in the textbook.  The geologic map is Figure 3-11H.  
 Also look at Plate 7.  We’ll examine the spectral characteristics of the Red  Rose 
 Anticline and the agricultural fields in the upper right along the Wind River. 

2) Let’s examine each of the 9 bands.  Right-click on the file name in the Layer Manager 
> Band Animation.  ENVI flickers through the 9 bands rapidly(!) by default. 

 

 Slow down ENVI….Use the dropdown menu in the lower left of the Band 
 Animation tool to choose 2 seconds or 5 seconds. 

Question 1: Which band is most unlike the other 8 bands? 

3) Let’s load 7 of the individual bands.  Open the “Bands” subfolder that is in the 
Remote Sensing Digital Data chapter 3 folder named  “Plates_7and27_Thermopolis”.   

 Landsat OLI bands 2-7 and 10 are available for loading into ENVI. 

 Highlight the seven TIFF images with the Control (Ctrl) Key down and click Open 

 Turn-off all the bands in the View except “Band 10 Thermal_tif.tif” in the Layer 
 Manager View 

  Right-click on Band 10 in the Layer Manager and View Metadata.   

   What is the pixel size of this thermal IR band? _____ 

  Right-click on Band 6 in the Layer Manager and View Metadata.   

   What is the pixel size of this SWIR1 band? _____ 
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 The Landsat 8  TIR sensor acquires thermal IR bands 10 and 11 with 100 x 100 
 m pixels.   The Landsat 8 OLI sensor acquires VNIR-SWIR bands 1 to 7 with 30 
 x 30 m pixels.  The USGS resamples the thermal IR bands to 30 x 30 m pixels 
 for delivery to users. 

Question 2: Why are the Landsat 8 thermal IR bands collected with pixels that cover an 
area more than 100 times larger than the VNIR-SWIR 30 x 30 m pixels?  

  (see Equation 1-2 and Table 3-1 in the textbook) 

4) Turn on Landsat OLI band 5 NIR.  Right click > Quick Stats 

 Select Plot > Histogram Band 1 (Drop-down menu in upper left of Quick Stats) 

 This Landsat band was resampled to 8-bit from the original data delivered by  
 the USGS and contrast-stretched for the textbook figure.  You are viewing a 
 contrast-stretched grayscale image (you would not know this unless the remote 
 sensing analyst documented the radiometric change in the metadata). 

Question 3:  A. What is the Mean and Standard Deviation of all the pixels in the   
  grayscale Band 5 NIR? 

  B. What percentage of pixels have values within one standard deviation of 
  the mean?  (see textbook Figure 9-3 for explanation) 

  C. What digital number (DN) is displayed by the most pixels (Data Value  
  on the horizontal axis of the histogram)?  How many pixels have that DN  
  (“Count” value)?  What percentage of the 256 DNs is contained by this  
  largest DN? 

5)  Let’s zoom into the area shown in the textbook’s Figure 9-2.  Turn on Landsat band 
5 NIR.  Load the UTM Zone 13 vector polygon shapefile named “Textbook Fig 9-2 
Thermopolis.shp” that is in the Lab_2_Data folder.   

 File > Open > “Textbook Fig 9-2 Thermopolis.shp”   (the type of file to load is 
 designated “SHP”.  Many files are required to support a shapefile(!) 

 Right click on the shapefile in the Layer Manager > Properties > change “Line 
 Thickness” to 3  >   Change “Line Color” to black so that the rectangular polygon 
 is displayed more clearly. 

 We want to replicate some of Figure 9-2.  Turn-off all images and bands except 
 Band 5 NIR.  Display the band 5 with “No Stretch”.   You have to keep 
 highlighting “Band 5 NIR” in the Layer Manager while the vector shapefile is 
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 turned-on to use tools and to see information about the raster band 5. 
  Zoom-in so the polygon fills your View 

 Display > Cursor Value    Move the crosshairs around the image with the Select  
     tool (arrow) 

 What is the brightest DN value for band 5?  What is the darkest DN value for 
 band 5? 

 Turn-off the shapefile.  Highlight Band 5 NIR in the Layer Manager 

  Display > Profiles > Arbitrary 

  Draw a profile that mimics a – a’ on Figure 9-2A  (keep clicking until the  
  profile pops up in a window). What do you see as the high and low DNs  
  (see figure below).   

 

a- a’ profile of Band 5 NIR 

6) Let’s look at band 5 in the 9-band dataset (Thermopolis_Landsat8_bands1-7_10-
11_30m_ENVI_).  Highlight this color composite in the Layer Manager.  Change the 
band combination to a 7-5-2 as red-green-blue. 

 Right-click the 9-band Landsat dataset in the Layer Manager > Change RGB  
 Bands…     The bands in this dataset have the original DNs delivered by the 
 USGS.  

 Right click on the 9—band Landsat dataset > Quick Stats        

  Select Plot >  Histogram Band 5  
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Question 4:  A. What is the Mean and Standard Deviation of all the pixels in the  
  9-band Landsat dataset’s Band 5 NIR? 

  B.  Scroll down (or use the “Locate Stat” dropdown menu) and select Band 
  5.   Computer screens can typically only display 256 levels (DNs) of  
  brightness. So each DN on the histogram and your computer screen  
  contains many DNs from the original USGS data.  How many original DNs 
  are contained within each DN displayed in the histogram and on the  
  computer screen (look for “binsize =….”)   

  C. What range of original USGS digital numbers (DN) have the highest  
  count in band 5?   

  D. How many pixels (the “Count” value) in band 5 have the highest DN? 

  E. The USGS delivers Landsat 8 OLI and TIR bands with 16-bit   
  radiometric resolution!  How many levels of brightness is available with 16- 
  bit data?    
 
   NOTE:  The Landsat 8 system collects the data with 12-bit   
   radiometric resolution (see Textbook Table 3-3). 

7) Let’s examine a color IR image generated from the  “Thermopolis_Landsat8_bands1-
7_10-11_30m_ENVI_” dataset.  The area we are evaluating continues to be within the 
shapefile and the textbook Figure 9-2. 

 Right-click on the file name in the Layer Manager and Change RGB bands… 

  Generate a color IR image (Bands 5-4-3 or NIR-red-green in R-G-B).  To  
  see what bands are displayed you have to click on the “+” sign to the left  
  of the file name. 
  Zoom to Full Extent 

  Contrast-stretch the color IR image – use the “Linear 2%” stretch 

 Display > Cursor Value    Move the crosshairs around the image with the Select  
 tool (arrow).  The DNs for the 3 bands are displayed in the “Data:” field. 

 What is the approximate brightest DN value for band 5 NIR?  What is the 
 approximate darkest DN value for band 5 NIR? 

 Turn-on the shapefile.  Zoom-in to the shapefile polygon.   Highlight the 9-band 
 Landsat dataset in the Layer Manager 
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  Display > Profiles > Arbitrary 

  Draw a profile that mimics a – a’ on Figure 9-2A.  Where do you see the  
  high and low DNs for Band 5? 

Question 5:  A. How is the DN profile from the enhanced grayscale Band 5 NIR (shown  
  above) compare with the DN profile from the original USGS data for Band  
  5 NIR (seen as a red line in the profile (not shown))?   

  B. What is different about the profiles?  (Do not include the difference in  
  the “Data Value” on the vertical axis) 

  C. Why the difference in the profiles?  (Hint: what is different in the image  
  processing?) 

Question 6:  Reflected near IR light is very bright (high Data Value) over irrigated 
agricultural fields on your Arbitrary Profile across the original USGS Landsat data.  On 
this same plot, what happens to the reflected red light (band 4) over irrigated agricultural 
fields in comparison to reflected green light (band 3)?  Any idea why this occurs? 

8) Let’s look at the brightness values of the 9 bands in the 
“Thermopolis_Landsat8_bands1-7_10-11_30m_ENVI_” dataset.  Highlight the color IR 
image in the Layer Manager.  The bands in this dataset have the original DNs delivered 
by the USGS.  

 Right click on the 9—band Landsat dataset > Quick Stats        

 The horizontal axis labelled “Unknown” represents the band number.  The visible 
bands are 1-4, the NIR band is 5, the SWIR bands are 6 and 7, and the thermal IR 
bands are 8 and 9 on the horizontal axis.  The “Data Value” vertical axis represents the 
16-bit DNs (brightness value ) that are delivered with Landsat 8 radiance data.  See 
below. 
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Question 7:   A. Explain the statistical plot above.  (also look at the metadata table) 

  B. What band has the highest mean DN? 

  C. What band has the highest DN range? 

  D. What band has the largest standard deviation? 

9) Zoom out on the color IR image so that you see the Red Rose Anticline and the 
agricultural fields (perhaps with a map scale of 1:100,000).  Let’s look at a spectral 
profile at individual pixels. 

 Display > Profiles > Spectral 

 Move the crosshairs around with the select arrow and click on different pixels.   

  Examine the profile at the following features: 

   Irrigated agricultural field 
   Wind River 
   Airport  
   Different color geologic outcrops 

  What band varies the most?  What bands vary the least?   
    

10) Let’s change the Color IR image in our View to a natural color image. 

 Right-click on 9-band Landsat data set in Layer Manager > Change RGB Bands 
 > Select Band 4 - Band 3 - Band2 as R-G-B > OK  > Zoom to Full Extent > 
 Contrast Stretch to “Linear 2%” 

Now let’s generate 4 Views and load three other band combinations in each one, then 
link the four views so we can pan and zoom in and out and easily compare the different 
colors composites. 

Views > 2 X 2 Views      We’ll load the empty Views using the Data Manager. 
 
Highlight View 2 (upper right) with your cursor.  Data Manager > Select Band 5 – Band 
4 – Band 3 as R-G-B in the 9-band Landsat data set  > Load Data  > Zoom to Full 
Extent > Contrast Stretch to “Linear 2%” 

Highlight View 3 (lower left) with your cursor.  Data Manager > Select Band 7 – Band 5 
– Band 2 as R-G-B in the 9-band Landsat data set  > Load Data  > Zoom to Full Extent  
> Contrast Stretch to “Linear 2%” 
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Highlight View 4 (lower right) with your cursor.  Data Manager > Select Band 7 – Band 6 
– Band 5 as R-G-B in the 9-band Landsat data set  > Load Data  > Zoom to Full Extent 
> Contrast Stretch to “Linear 2%” 

 To see what bands are displayed you have to click on the “+” sign to the left of 
 the file name. 

 Turn-off all other images and shapefile in the Layer Manager .  Each View should 
 only have the color composite checked in the Layer Manager and displayed. 
 
Now we will link the four Views.   
 Views > Link Views  >   GeoLink active >   Link All    > OK 
  Pan around     Zoom in & out 
 
Question 8: List the colors displayed with the different color composites in the 
agricultural fields along the Wind River.  Zoom in on a field with much irrigation and 
vigorous crops and a field with limited irrigation and less vigorous crops to fill in the 
blanks on the table. 

  a) natural color (red-green-blue in R-G-B),  

  b) color IR (NIR-red-green in R-G-B) 

  c) enhanced color (SWIR2-NIR-blue in R-G-B) 

  d) total IR (SWIR2-SWIR1-NIR in R-G-B) 

11)  Close 3 of the 4 Views.   
 Right-click on “View” in the Layer Manager >  Remove View  
 In the remaining View > Zoom to Full Extent 

We will now examine the correlation between the different bands using the Scatter Plot 
Tool.  We will be working with the same  
  “Thermopolis_Landsat8_bands1-7_10-11_30m_ENVI_” dataset.  
 Change RGB Bands > 5-4-3 as red-green-blue (color IR) 
 Turn off other layers in your Layer Manager.   
 You will be doing statistical analysis using all the pixels in each band. 

 Display > 2D Scatter Plot     (Picture below)  
  Press the “Toggle Density Slice” tool (upper center) to see the pixel  
  density scaled to color.   
  Click the “Full Band” box.   
  Change the Class 1 color from default red to yellow. 
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 White areas in the scatterplot show where the highest number of pixels
 overlap between the two bands while black areas have the least number of 
 overlapping  pixels. 

 Start with bands 1 versus 2, and work your way through band combinations.  
 Ignore the thermal bands (# 8 and 9 in the Scatter plot) 

 Note how band 5 NIR is significantly different from the other VNIR-SWIR bands 

 Display Band 5 NIR versus Band 4 Red in the color Scatter plot  
 (see picture below).  On the image in the ENVI View, as you  
 move your mouse around you should see a small square. 
 If you don’t, close the scatter plot tool, highlight the 9-band 
 Landsat dataset in the Layer Manager and reopen the 2D scatterplot display 
  Display > 2D Scatterplot 

  As you move your mouse over irrigated agricultural fields – you will see the color 
 IR red pixels display where the Band 5 NIR have high DN values and the Band 4 
 Red have low DN values in the scatterplot.  The image is connected to the 
 Scatter plot! 

 On the scatter plot, draw a polygon around the pixels with high Band 5 NIR DNs 
 and low Band 4 Red DNs.  This is “Class 1”.  (see below).  You will see those 
 pixels that have band 5 and band 4 pixels within your polygon light up on the 
 color IR image!  You have identified vigorous vegetation in the agricultural fields. 
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 Let’s upload the Landsat color image with the Class 1 pixels highlighted to the 
 instructor as a “geospatial pdf”. 

 File > Export View To > GeoSpatial pdf    (the pdf has coordinates!) 

  Briefly fill in the blanks on the form (this is metadata!) 

  Name the pdf “Your Name_Landsat_vig_veg” 

12) Now we will use the scatter plot tool to display the spectral characteristics of   select 
features that you will map with ENVI’s ROI (region of interest) tool. 
 Clear the yellow Class 1 on the scatterplot.  Options > Clear Class 

   Use the Toggle Density Tool (upper center) to change 
      to a Black pattern for the pixel distribution. 

 Go to the main ENVI display to access the ROI tool. 
 File > New > Region of Interest    The Region of Interest (ROI) Tool pops up  
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We will create 4 ROIs using the default Geometry > polygon tool in the menu above.  
The ROIs will represent: 
  Irrigated vigorous vegetation  
  Water in the Wind River 
  Outcrop of the Chainman Shale 
  Airport tarmac (asphalt?) 

 
We will display the Landsat as a 7-5-2 as R-G-B color image.  Use a Linear 2% stretch. 

We will use a GIS vector shapefile that has each of the four features above mapped as 
points.  Draw your ROI polygon around those pixels near the shapefile point that are 
“pure” pixels for the feature of interest. Don’t mix other pixels as that will degrade the 
spectral signature of our four features of interest. 

 File > Open   open the “Lab_2_Data” folder and select the 
    “ROI_sites on Thermopolis Landsat.shp” file.  (the SHP File). 

The four points will display on the ENVI view.  The points are located across the center 
of the image.  They are difficult to see!  Right-click on the ROI sites shapefile in the 
Layer Manager and change the Properties – enlarge the “Point Size” to “20”.  Maybe 
change the color to “Black”. 

 Location of shapefile points 



12 
 

12 Introduction to Remote Sensing  Principles, Interpretation, and Applications 
F. F. Sabins and J.M. Ellis, 2020, Waveland Press.    Contact:  jellis@ellis-geospatial.com 

 

If you can’t see the shapefile points clearly, the longitude and latitude coordinates are 
provided below.  Drive your Zoom tool (enables zooming in with a rectangle area of 
interest) to each point, zoom-in, and create a polygon ROI. 

  

 

 

  

 

 a) Zoom into the vigorous agricultural field and draw a ROI polygon within the 
 bright green pixels.  Double-click at the end of your polygon line to close the  
 polygon and create the ROI 
  Rename the ROI #1 to “Irrigated vegetation”.    
  Click-on the upper left icon “New ROI” to create a new ROI. 

 b) Zoom into the Chainman Shale outcrop and draw a ROI polygon within the 
 yellow-orange to orange pixels. 
  Rename the ROI #.. to “Chainman Shale”.   
  Click-on the upper left icon “New ROI”. 

NOTE:  the polygons and ROIs can get mixed up.  You may have to       
delete an ROI, edit the name (right-click on the ROI in the Layer Manager), 
and redo an ROI.  Look at the Layer Manager and Data Manager       
to see if you are correctly making four ROIs over four areas on the          
Landsat image.  If you get two polygons in your ROI, just use the Record 
Count at the bottom of the ROI Tool and delete the incorrect polygon.  
PATIENCE!! 

 c) Zoom into the Airport tarmac and draw a ROI polygon within the darkest 
 pixels.  (change the shapefile color from black to yellow so you can see it…) 
  Rename the ROI #.. to “Airport tarmac”.   
  Click-on the upper left icon “New ROI”. 

 d) Zoom into the Wind River water and draw a ROI polygon within the  
 darkest pixels.   
  Rename the ROI #.. to “Water”.   
 
You should see the four ROIs under a folder named “Regions of Interest” in the Layer 
Manager.  Let’s rename this folder  

Feature of Interest Longitude Latitude 

Irrigated Vegetation -108.1263 43.7313 

Chainman Shale -108.2886 43.6956 

Airport tarmac asphalt -108.3788 43.7161 

Water -108.1574 43.7012 
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 Right-click “Regions of Interest” folder  > Save As    
     “Your Name_ROIs_for_ScatterPlot” 

NOTE: You can also save the four ROIs using the Regions of Interest (ROI) 
Tool.  File > Save As     Click-on the “Select All Items” button.  

13) Now let’s see where these four ROIs are located on our scatter plot. 
 First you have to highlight the 9-band Landsat data in the Layer Manager! 
 Display > 2D Scatter Plot  (if not already opened) 
        Choose band 4 on the vertical axis and band 5 on the horizontal axis. 
 
 Use the Toggle Density Slice to make the scatter plot black. 

 On the Scatter Plot Tool   File > Import ROIs 
  You should see the 4 ROIs you just created(!)    
  Push the “Select All Items” button. 
 You will the pixels that match your ROI spectral signatures show up on the  
 black scatter plot with default colors.  Let’s change the colors to brighter shades. 

  

Chainman Shale 

Water 

Airport  
tarmac 

Irrigated Vegetation 
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 The ROIs reveal that each of the classes has a unique spectral signature that is 
 differentiated on the band 4 (red) versus band 5 (NIR) scatter plot!  You also see 
 the same-color pixels on the image in the ENVI view.  There are few asphalt 
 pixels and no (?) water pixels outside the Wind River with the same spectral  
 characteristics as our ROIs. 

 Save the scatter plot as an image      File > Save Plot As > Image. 

  Name the plot “Your Name_Scatterplot_with_ROIs” 

  Upload the .jpg or .png image to the instructor 
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Lab 2 Multispectral Landsat Processing   Name: 

Upload the following files to the instructor: 
 
 (11) “Your Name_Scatterplot_map.pdf”   
 
 (13) “Your Name_Scatterplot_with_ROIs.png” 

Question 1: Which band is most unlike the other 9 bands? 

Question 2: Why are the Landsat 8 thermal IR bands collected with pixels that cover an 
area more than 100 times larger than the VNIR-SWIR 30 x 30 m pixels?  
  (see Equation 1-2 and Table 3-1 in the textbook) 

Question 3:  A. What is the Mean and Standard Deviation of all the pixels in the   
  grayscale Band 5 NIR? 

  B. What percentage of pixels have values within one standard deviation of 
  the mean?  (see textbook Figure 9-3 for explanation) 

  C. What digital number (DN) is displayed by the most pixels (Data Value  
  on the horizontal axis of the histogram)?  How many pixels have that DN  
  (“Count” value)?  What percentage of the 256 DNs is contained by this  
  largest DN? 

Question 4:  A. What is the Mean and Standard Deviation of all the pixels in the  
  9-band Landsat dataset’s Band 5 NIR? 

  B.  Scroll down (or use the “Locate Stat” dropdown menu) and select Band 
  5.   Computer screens can typically only display 256 levels (DNs) of  
  brightness. So each DN on the histogram and your computer screen  
  contains many DNs from the original USGS data.  How many original DNs 
  are contained within each DN displayed in the histogram and on the  
  computer screen (look for “binsize =….”)   

  C. What range of original USGS digital numbers (DN) have the highest  
  count in band 5?   

  D. How many pixels (the “Count” value) in band 5 have the highest DN? 

  E. The USGS delivers Landsat 8 OLI and TIR bands with 16-bit   
  radiometric resolution!  How many levels of brightness is available with 16- 
  bit data?    
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Question 5:  A. How is the DN profile from the enhanced grayscale Band 5 NIR (shown  
  above) compare with the DN profile from the original USGS data for Band  
  5 NIR (seen as a red line in the profile (not shown))?   

  B. What is different about the profiles?  (Do not include the difference in  
  the “Data Value” on the vertical axis) 

  C. Why the difference in the profiles?  (Hint: what is different in the image  
  processing?) 

 

 

Question 6:  Reflected near IR light is very bright (high Data Value) over irrigated 
agricultural fields on your Arbitrary Profile across the original USGS Landsat data.  On 
this same plot, what happens to the reflected red light (band 4) over irrigated agricultural 
fields  in comparison to reflected green light (band 3)?  Any idea why this occurs? 

 

 

Question 7:   A. Explain the statistical plot.  (also look at the metadata  table) 

  B. What band has the highest mean DN? 

  C. What band has the highest DN range? 

  D. What band has the largest standard deviation? 
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Question 8: List the colors displayed with the different color composites in the 
agricultural fields along the Wind River.  Zoom in on a field with much irrigation and 
vigorous crops and a field with limited irrigation and less vigorous crops to fill in the 
blanks on the table. 

 

     Features of               
Interest 

 
 
 

OLI Bands__      

Agriculture 
fields with 

much 
irrigation and 

vigorous 
crops 

Agriculture 
fields with 

limited 
irrigation and 
less vigorous 

crops 

Natural Color 
OLI 4-3-2 

as 
R-G-B 

  

Color IR 
OLI 5-4-3 

as 
R-G-B 

  

Enhanced 
Color 

OLI 7-5-2 
as 

R-G-B 

  

Total IR 
OLI 7-6-2 

as 
R-G-B 

  


